Back to overview
Degraded

Website (bath.ac.uk) - Performance Issues

Sep 14, 2026 at 9:17am UTC
Affected services
Website (bath.ac.uk)

Updated
Sep 14, 2026 at 2:00pm UTC

We are continuing to investigate performance issues affecting the University of Bath website.

We will provide further updates as soon as possible and apologise for any inconvenience caused.

Created
Sep 14, 2026 at 9:17am UTC

We are investigating performance issues affecting the University of Bath website.

We will provide further updates as soon as possible and apologise for any inconvenience caused.