Back to overview
Degraded

AdminDesk - Connection issues

Sep 15, 2026 at 2:13pm UTC
Affected services
UniDesk, UniApps, AdminDesk

Updated
Sep 15, 2026 at 4:12pm UTC

Following our earlier update, maintenance to resolve the Admin Desk connection issues will take place out of hours today (Tuesday 15th September). Users may notice brief periods of downtime.

Thank you for your patience, and we apologise for any disruption.

Updated
Sep 15, 2026 at 2:50pm UTC

We have identified the cause of the problem and are currently testing a fix.

We will provide a further update shortly.

Created
Sep 15, 2026 at 2:13pm UTC

We are currently investigating connection issues affecting Admin Desk.

We will provide further updates as soon as possible and apologise for any inconvenience caused.