MassHunter - Connection issues
Updated
Sep 24, 2026 at 1:41pm UTC
We have identified the problem with MassHunter and are undertaking maintenance to resolve the issue, we hope this work will be completed by 5pm today.
Affected services
Updated
Sep 24, 2026 at 12:22pm UTC
Unfortunately the issues with accessing MassHunter have persisted and we are continuing to investigate.
Affected services
Updated
Sep 24, 2026 at 9:52am UTC
This issue is now resolved.
Thank you for your patience while we investigated and resolved this issue.
Affected services
Created
Sep 24, 2026 at 9:44am UTC
We are currently investigating connection issues affecting MassHunter.
We will provide further updates as soon as possible and apologies for any inconvenience caused.
Affected services