Back to overview
Degraded

Issue affecting Business World (Agresso)

Mar 19 at 12:01pm GMT
Affected services
Business World (Agresso)
Business World (Agresso) Marketplace

Resolved
Mar 19 at 04:28pm GMT

Normal Business World (Agresso) service is resumed.

Created
Mar 19 at 12:01pm GMT

We have been made aware of an issue with Agresso.

It appears as though you can log in as normal, however many screens in the application will not work as expected. We have identified the root cause of the problem and we are currently working on rectifying the issue as a priority.