Back to overview
Degraded
Incident search functionality is currently unavailable
Apr 29 at 11:07am BST
Affected services
Self-Service Portal (TOPdesk)
Resolved
Apr 29 at 01:56pm BST
This issue has now been resolved.
Affected services
Self-Service Portal (TOPdesk)
Created
Apr 29 at 11:07am BST
Incident search functionality is currently unavailable. TOPdesk are aware of the issue and are working on a resolution.
Affected services
Self-Service Portal (TOPdesk)