Back to overview
Degraded

Issue affecting Business World (Agresso) sign-ins

May 02 at 11:20am BST
Affected services
Business World (Agresso)

Resolved
May 02 at 01:07pm BST

This issue is now resolved.

Updated
May 02 at 12:08pm BST

Our Agresso Technical team have implemented a fix, and believe that this issue should now be resolved. We are awaiting confirmation from affected stakeholders before marking this incident as resolved.

Created
May 02 at 11:20am BST

We have received reports of an issue affecting signing in to Agresso that appear to be MFA callback related. The Agresso Technical team are aware & are investigating the issue.