Back to overview
Degraded

Issue affecting sending emails via TOPdesk

Jun 17 at 09:35am BST
Affected services
Help Portal (TOPdesk)

Resolved
Jun 17 at 11:01am BST

This issue has now been resolved.

Updated
Jun 17 at 10:04am BST

TOPdesk are currently experiencing problems in their UK1 hosting location: "as a result, outgoing mails may be impacted and some users could also experience performance issues. We are aware of the problem and are working on a solution."

Updated
Jun 17 at 09:44am BST

TOPdesk have confirmed that this is a wider issue, and they are investigating.

Created
Jun 17 at 09:35am BST

We’re investigating an issue with TOPdesk that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.