Back to overview
Degraded

Poor/reduced Remote Desktop performance via VPN

Jul 11 at 09:00am BST
Affected services
UniDesk and AdminDesk
VPN

Resolved
Jul 12 at 09:00am BST

Our technical resolver teams have now implemented a workaround that should improve performance when accessing devices via Remote Desktop (and VPN). You may need to restart both your local and remote devices in order for them to pick up the policy change.

This issue is now resolved.

Updated
Jul 11 at 01:57pm BST

Our technical resolver teams have identified a potential workaround, and are working to get it implemented as soon as possible.

Created
Jul 11 at 09:00am BST

We have identified an issue causing reduced performance when using remote desktop via VPN from off-site locations, and are currently investigating.

We will provide further updates as soon as possible and apologise for any inconvenience.