Back to overview
Degraded

Issue affecting Teams desk phones

Oct 30 at 08:40am GMT
Affected services
Telephony

Resolved
Oct 30 at 09:55am GMT

This issue is now resolved.

Created
Oct 30 at 08:40am GMT

We are currently investigating an issue impacting Teams desk phones, where devices have unexpectedly signed out. Our team is actively working to sign back in the 209 affected handsets across campus and restore normal service as soon as possible.

We will provide further updates as soon as possible, and apologise for any inconvenience caused.