CRMs (D365) not sending or receiving email
Resolved
Nov 26 at 11:05am GMT
Our technical resolver team has checked all CRMs, and can confirm that this issue is now resolved.
Affected services
CRM (Microsoft Dynamics 365)
Updated
Nov 26 at 10:50am GMT
Tracking functionality is now operational, and Microsoft has confirmed that the root cause of the initial issue has been resolved.
The queues screen may display intermittent issues that may impact users. Errors can occur when using filters, interacting with columns, or switching between queues.
Fully refreshing (CTRL + F5) the page typically resolves these problems.
We are actively monitoring the situation, and will ensure that all residual issues are completely resolved.
Affected services
CRM (Microsoft Dynamics 365)
Updated
Nov 26 at 08:15am GMT
Tracking appears to have resumed around 8 PM, and cases are now visible in the system. We are monitoring the situation before marking it as resolved.
Affected services
CRM (Microsoft Dynamics 365)
Updated
Nov 25 at 04:40pm GMT
Microsoft have advised that the issue is on their end: "exchange infrastructure responsible for processing email requests is experiencing an outage, leading to impact. We are currently reviewing service diagnostic information to identify the root cause of the issue and determine our next mitigating actions."
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
CRM (Microsoft Dynamics 365)
Created
Nov 25 at 04:20pm GMT
We are investigating an issue affecting our CRM solution (Dynamics 365).
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
CRM (Microsoft Dynamics 365)