Back to overview
Degraded

Issue affecting various M365 services

Jan 21 at 12:45pm GMT
Affected services
CRM (Microsoft Dynamics 365)
Email and Calendar
Microsoft Power BI
Microsoft Teams

Resolved
Jan 22 at 09:00am GMT

We can confirm this morning that this issue is now resolved.

Updated
Jan 21 at 02:30pm GMT

Some of the symptoms, such as calendars not showing within Teams, and some are struggling to create Teams meetings in Outlook, appear to now be resolved.

We are continuing to investigate the other symptoms/issues.

Created
Jan 21 at 12:45pm GMT

We are investigating an issue affecting various M365 services, including, but not limited to:
- Teams Calendar Integration
- Outlook > CRM link (automated harvester)
- Power Automate
- MS Bookings

Users are reporting a variety of symptoms, including sync errors, calendars not showing within Teams, and some are struggling to create Teams meetings in Outlook.

Our M365 Team are investigating, although we believe that this may be a global issue.

We will provide further updates as soon as possible, and apologise for any inconvenience caused.