Back to overview
Degraded
Power Issues in 10 East Affecting the Network
Jan 29 at 04:52pm GMT
Affected services
Network and Internet
Resolved
Jan 30 at 09:00am GMT
This issue is now resolved.
Affected services
Network and Internet
Created
Jan 29 at 04:52pm GMT
Campus Infrastructure is investigating a power issue in 10 East, which is impacting network services, as our equipment relies on power.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Network and Internet