Back to overview
Degraded
Phone Service Issue
Mar 18 at 08:47am GMT
Affected services
Telephony
Resolved
Mar 18 at 08:57am GMT
This issue is now resolved.
Affected services
Telephony
Created
Mar 18 at 08:47am GMT
We’re currently experiencing issues with calls to and from the University. Our team is investigating. Thank you for your patience.
Affected services
Telephony