Back to overview
Degraded
Network and Wi-Fi issue in Clevelands, Canal Wharf & Holburne Museum
May 14 at 08:35am BST
Affected services
Network and Internet
Resolved
May 14 at 09:35am BST
This issue is now resolved.
Affected services
Network and Internet
Updated
May 14 at 09:05am BST
Our Networking team has confirmed a loss of power to Clevelands Building and has notified the Campus Operations team, who will attend to resolve the issue.
We will provide further updates as soon as possible and apologise for any inconvenience caused.
Affected services
Network and Internet
Created
May 14 at 08:35am BST
We are investigating an issue affecting the network (including Wi-Fi) in Clevelands, Canal Wharf & the Holburne Museum.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Network and Internet