Back to overview
Downtime

Issue affecting MyTimetable

May 20 at 03:30pm BST
Affected services
Timetabling

Resolved
May 21 at 08:15am BST

This issue is now resolved.

Created
May 20 at 03:30pm BST

We are investigating an issue affecting MyTimetable.

We will provide further updates as soon as possible, and apologise for any inconvenience caused.