Back to overview
Degraded

Issue affecting Examinations Timetables (SAMIS)

May 21 at 08:25am BST
Affected services
SAMIS

Resolved
May 21 at 08:45am BST

This issue is now resolved.This issue is now resolved.

Created
May 21 at 08:25am BST

We are investigating an issue affecting Examinations Timetables (SAMIS).

We will provide further updates as soon as possible, and apologise for any inconvenience caused.