Back to overview
Degraded
Network and Wi-Fi disruption in Canal Wharf
May 28 at 07:55am BST
Affected services
Network and Internet
Resolved
May 28 at 11:45am BST
This issue is now resolved.
Affected services
Network and Internet
Created
May 28 at 07:55am BST
We are investigating an issue affecting the network (including Wi-Fi) in Canal Wharf.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Network and Internet