Back to overview
Degraded

CAFM - Service Unavailable

Jul 02 at 09:05am BST
Affected services
Software

Resolved
Jul 02 at 10:00am BST

This issue is now resolved.

Created
Jul 02 at 09:05am BST

We are investigating an issue affecting CAFM.

We will provide further updates as soon as possible, and apologise for any inconvenience caused.