Back to overview
Degraded
SAMIS - Performance Issues
Jul 17 at 11:55am BST
Affected services
SAMIS
Resolved
Jul 17 at 02:20pm BST
This issue is now resolved.
Affected services
SAMIS
Created
Jul 17 at 11:55am BST
SAMIS Web is currently experiencing severely degraded performance, likely due to high demand on results day. Our teams are investigating and working to restore normal service as soon as possible.
Affected services
SAMIS