Back to overview
Degraded
Issue creating and issuing new user accounts
Oct 02 at 03:44pm BST
Affected services
Accounts and Passwords
Created
Oct 02 at 03:44pm BST
We are currently experiencing issues with our account admin centre and are unable to issue new user accounts, we are working to resolve.
Affected services