Back to overview
Degraded
TOPdesk Self Service Portal Unavailable Message
Oct 04 at 10:44am BST
Affected services
Self-Service Portal (TOPdesk)
Resolved
Oct 04 at 11:06am BST
This issue has now been resolved.
Affected services
Created
Oct 04 at 10:44am BST
We are aware of an issue affecting our TOPdesk self service portal which is causing a TOPdesk is unavailable message when logging tickets, however tickets are still being logged and you should still receive an email and ticket number, we are investigating the cause.
Affected services