Back to overview
Degraded

Agresso - Intermittent "Server Error"

Oct 09 at 09:45am BST
Affected services
Business World (Agresso)

Resolved
Oct 10 at 08:00am BST

The issue has now been resolved, and services should be restored to normal operations. If you experience any further difficulties, we recommend clearing your browser cache and cookies, as this often resolves residual access problems.

Updated
Oct 09 at 03:55pm BST

We’re aware that some users are still experiencing intermittent issues accessing Agresso. While access has improved and many users can now log in, the service is not yet fully stable.

Our teams, along with the supplier, continue to monitor the situation closely to ensure full restoration of service.

Updated
Oct 09 at 12:00pm BST

Microsoft have identified a capacity issue within one of their Azure services that was affecting Microsoft 365. They are in the process of restoring the affected systems, and signs of recovery are already being seen. We’ll continue to monitor and provide updates until the service is fully restored.

Updated
Oct 09 at 11:20am BST

Microsoft have acknowledged an issue affecting Microsoft Entra/Azure services. This is a Europe-wide incident and not specific to our environment.

We will provide further updates as soon as possible and apologise for any inconvenience caused.

Created
Oct 09 at 09:45am BST

We are investigating an issue affecting Agresso where users may intermittently encounter a “Server Error” message. We believe this may be related to the Microsoft Entra/Azure issues that are being reported across the country.

Some users have found that retrying several times allows them to successfully log in.

We will provide further updates as soon as possible and apologise for any inconvenience caused.