Back to overview
Degraded
Teams Calling - Intermittent Issues
Oct 23 at 09:15pm BST
Affected services
Telephony
Updated
Oct 24 at 04:10pm BST
Following extensive investigations by DDaT teams, the issue has been narrowed down to a fault outside of the University's network, the network providers have confirmed the fault and are actively working to resolve it.
Affected services
Created
Oct 23 at 09:15pm BST
We are aware of and continuing to investigate reports of intermittent issues affecting both incoming and outgoing calls via Teams Calling.
We will provide further updates as soon as possible and apologise for any inconvenience caused.
Affected services