Back to overview
Degraded
Wi-Fi & Ethernet - Clevelands Building
Nov 04 at 10:20am GMT
Affected services
Network and Internet
Resolved
Nov 04 at 10:45am GMT
Service has now been restored following an outage of around 20 minutes. We believe the issue was power-related, but we are awaiting confirmation from Campus Infrastructure.
Affected services
Created
Nov 04 at 10:20am GMT
We are investigating an issue affecting network connectivity in the Clevelands Building.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services