Back to overview
Degraded
Secure Downloads - 'Service Unavailable' Error
Nov 06 at 10:05am GMT
Affected services
Software
Resolved
Nov 06 at 10:08am GMT
This issue is now resolved.
Affected services
Created
Nov 06 at 10:05am GMT
We are investigating an issue affecting Secure Downloads, where users may see the error message “HTTP Error 503 – The service is unavailable.”
We will provide further updates as soon as possible and apologise for any inconvenience caused.
Affected services