Back to overview
Degraded

Cloudflare Issues

Nov 18 at 01:00pm GMT
Affected services
Software
Website (bath.ac.uk)
Other

Resolved
Nov 19 at 08:00am GMT

This incident has been resolved.

Updated
Nov 18 at 04:48pm GMT

According to Cloudflare: "We continue to see errors drop as we work through services globally and clearing remaining errors and latency."

Updated
Nov 18 at 04:29pm GMT

According to Cloudflare: "We continue to see errors and latency improve but still have reports of intermittent errors. The team continues to monitor the situation as it improves, and looking for ways to accelerate full recovery."

Updated
Nov 18 at 02:50pm GMT

According to Cloudflare: "A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal."

Created
Nov 18 at 01:00pm GMT

Cloudflare is currently experiencing service issues, as confirmed on their status page. This may impact various University services, including the University of Bath homepage, because Cloudflare provides web application security and performance services for much of the internet.