Back to overview
Degraded
SAMIS (Web) - Performance Issues
Apr 21, 2026 at 12:35pm UTC
Affected services
SAMIS
Resolved
Apr 23, 2026 at 9:45am UTC
This issue is now resolved.
Affected services
Updated
Apr 22, 2026 at 11:00am UTC
We are anticipating heavy demand on SAMIS today (Wednesday 22nd April). The system limits the number of concurrent users, so you may need to try again later if you experience login issues. Thank you for your patience.
Affected services
Created
Apr 21, 2026 at 12:35pm UTC
We have identified performance issues affecting SAMIS (Web). Users may experience slow page loading when accessing the system.
Our technical teams are actively investigating and working to restore full performance as quickly as possible.
Affected services