Back to overview
Degraded

X Drive - Issue Affecting 'Administration' & 'Professional Services' Areas

May 12, 2026 at 9:10am UTC
Affected services
File Storage and Sharing

Updated
May 13, 2026 at 9:25am UTC

The issue has now been resolved for the majority of areas within the Professional Services X Drive area. The Administration area was less impacted and is largely functioning as expected.

We are continuing to carry out thorough checks to ensure permissions have been applied correctly and consistently and to avoid introducing any further access issues.

We will provide a further update later this afternoon.

Updated
May 12, 2026 at 4:10pm UTC

Our technical resolver teams have been continuing to work to resolve the issue. The remediation process is entirely manual rather than automated, and we need to ensure that permissions are applied carefully and consistently to avoid introducing any further access issues.

Work will continue from tomorrow morning, and at this stage we anticipate that access will be restored to all affected areas during the day tomorrow.

Updated
May 12, 2026 at 1:00pm UTC

Our technical resolver teams have identified the cause of the permissions-related issues primarily affecting the Professional Services area of the X Drive and are working to implement a resolution.

This work may take some time, as the work is entirely manual (not automated), and we need to ensure permissions are applied correctly and thoroughly to avoid introducing any further access issues.

If you are still affected by this issue, could you please provide the full path you are attempting to access, for example:
X:/Professional Services/Department/Folder.

Kind regards,

Updated
May 12, 2026 at 11:22am UTC

Our technical resolver teams are continuing to investigate an issue primarily affecting the ‘Professional Services’ area of the X Drive following this morning’s File Storage - Migration (Professional Services & Administration) change.

We have, however, been informed by multiple users that the issues affecting the ‘Administration’ area of the X Drive have been resolved following a device restart.

We will provide further updates as soon as possible and apologise for any inconvenience caused.

Created
May 12, 2026 at 9:10am UTC

We are investigating an issue affecting the 'Administration' & 'Professional Services' areas of the X Drive following this morning's File Storage - Migration (Professional Services & Administration) change.

Users experiencing an “Access Denied” (or similar) error should restart their device, as this may resolve the issue.

We will provide further updates as soon as possible and apologise for any inconvenience caused.