Back to overview
Degraded

Wi-Fi - Partial Outage in 3 South

Jun 4, 2026 at 10:00am UTC
Affected services
Network (Ethernet & Wi-Fi)

Resolved
Jun 4, 2026 at 10:12am UTC

This issue is now resolved.

Created
Jun 4, 2026 at 10:00am UTC

We are currently investigating an issue affecting Wi-Fi connectivity in parts of Level 1, 3 South.

A fix is in progress and is expected to be implemented within the next 30 minutes.

We will provide further updates as soon as more information becomes available, and we apologise for any inconvenience this may be causing.