Teams - Issue on Teaching Room PCs
Updated
Jun 12, 2026 at 12:20pm UTC
We have identified the cause of the issue affecting the Microsoft Teams app on teaching room (GTA) PCs.
A fix has now been deployed, and the latest version of Teams is being rolled out to affected PCs. Most machines are expected to update by tomorrow morning.
Please note that the update will only install when no user is logged into the PC, to avoid interrupting active sessions.
Affected services
Created
Jun 12, 2026 at 10:50am UTC
We are currently investigating an issue where the Microsoft Teams app is not loading correctly on teaching room (GTA) PCs.
The application may appear to hang during startup. As a workaround, the web version of Teams remains available and unaffected.
We will provide further updates as more information becomes available.
Affected services