Dynamics / PowerApps - Degraded Performance
Updated
Jul 7, 2026 at 10:20am UTC
This issue continues to persist. According to Microsoft, "backend engineering teams remain actively engaged in the investigation. Currently, the issues are active."
We will provide further updates as soon as more information becomes available.
Affected services
Updated
Jul 2, 2026 at 9:38am UTC
This continues to be a problem and we are working directly with Microsoft to resolve.
Affected services
Updated
Jun 30, 2026 at 8:30am UTC
Microsoft has confirmed this as a known issue affecting Dynamics and Power Apps services, including our Applicant CRM.
While Microsoft continues to investigate, there has been limited progress towards a resolution, and users may continue to experience slow performance and intermittent reliability issues.
At present, no workaround or estimated resolution time has been provided by Microsoft. We remain in contact with the supplier and are monitoring updates closely.
We apologise for the ongoing disruption and will provide further updates as soon as new information becomes available.
Affected services
Created
Jun 26, 2026 at 8:25am UTC
Microsoft is currently investigating an issue affecting Dynamics and Power Apps, where users may experience slow performance and unreliable behaviour.
This issue is specifically impacting our Applicant CRM.
This issue originates from Microsoft and is under active investigation. A fix or workaround is not yet available.
We are monitoring the situation and will provide further updates as more information becomes available.
Affected services