Back to overview
Resolved

Eduroam - Potential Campus-Wide Disruption

Jul 15, 2026 at 9:38am UTC
Affected services
Network (Ethernet & Wi-Fi)

Resolved
Jul 15, 2026 at 11:00am UTC

This issue is now resolved.

Updated
Jul 15, 2026 at 9:50am UTC

Eduroam is now available again, and services appear to have returned to normal. We will continue to monitor the situation closely and provide further updates if required.

Created
Jul 15, 2026 at 9:38am UTC

We are investigating an issue affecting the eduroam Wi‑Fi network. Our Networking team has identified that one of the wireless core units appears to have failed.

Our wireless network is designed with resilience and redundancy built in, and we expect service to recover shortly while failover processes complete.

We will provide further updates as soon as possible and apologise for any inconvenience caused.