Back to overview
Resolved

https://www.bath.ac.uk/jobs/ Currently Unavailable

Aug 7, 2026 at 9:25am UTC
Affected services
Other

Resolved
Aug 7, 2026 at 10:30am UTC

This issue has now been resolved, we apologise for any inconvenience.

Created
Aug 7, 2026 at 9:25am UTC

We are aware of the issue and investigating the cause, we will provide an update as soon as we are able to.