Back to overview
Degraded
Network issues reported in 10 East (School of Management)
Sep 13 at 11:17am BST
Affected services
Network and Internet
Resolved
Sep 13 at 11:39am BST
The issues with the Wi-Fi seem to have been fixed. We have monitored and no further issues are showing.
Affected services
Network and Internet
Created
Sep 13 at 11:17am BST
We are investigating reports of network issues in 10 East (School of Management). We will update once we know more.
Affected services
Network and Internet