Back to overview
Degraded

Microsoft 365 Services including services which use Microsoft Log Ins

Nov 10 at 09:50am GMT
Affected services
Email and Calendar
Microsoft Teams
Software

Resolved
Nov 10 at 12:50pm GMT

Microsoft have now resolved this issue ans services are now working as expected.

Updated
Nov 10 at 11:15am GMT

Microsoft are continuing to investigate and have provided the following further information

The majority of problems reported are for impact to Microsoft Teams. Impact may include, but is not limited to:

Microsoft Teams
- Users may be unable to send and receive messages.
- Users may be unable to create new Chats or Channels.

Other services impacted include

Exchange Online
- Users may be unable to send or receive email.

Power Apps
- Users may be unable to access the service.

Power Automate
- Users may be unable to access the service.

Created
Nov 10 at 09:50am GMT

Some users may be experiencing problems with Microsoft 365 services, including Teams and Outlook, Microsoft are aware of the issue and are investigating.