Back to overview
Degraded

Unidesk performance is currently slow and log ins may fail

Nov 24 at 01:48pm GMT
Affected services
UniDesk and AdminDesk

Resolved
Nov 27 at 01:29pm GMT

This issue has now been resolved.

Created
Nov 24 at 01:48pm GMT

We are aware of the problems and are taking remedial action.