Back to overview
Downtime
bath-staff.libcal.com is currently unavailable
Dec 14 at 04:19pm GMT
Affected services
Software
Resolved
Dec 15 at 09:00am GMT
Following escalating this issue to LibCal we are pleased to say that the service is now operating as usual.
Affected services
Software
Created
Dec 14 at 04:19pm GMT
bath-staff.libcal.com is currently unavailable and rooms are not bookable through this resource. This is being investigated and we will update further when we know more.
Affected services
Software