Back to overview
Degraded

Issues connecting to eduroam from Windows 11 devices

Dec 15 at 03:02pm GMT
Affected services
Network and Internet

Resolved
Jan 22 at 10:18am GMT

Microsoft have resolved the issue through a Windows Update release in Jan 2024

Updated
Dec 20 at 02:26pm GMT

Microsoft have now acknowledged the issue and have released guidance on what actions can be taken to resolve.

Created
Dec 15 at 03:02pm GMT

Users of Windows 11 devices may find that, following a recent Microsoft update they may experience issues connecting to eduroam.

The issue may be remediated through uninstalling the affected KB5033375 update, but this is not an action that we recommend, as it also includes security fixes.