Back to overview
Degraded

Exam Timetable Currently Unavailable

Jan 18 at 08:44am GMT
Affected services
SAMIS

Resolved
Jan 18 at 09:03am GMT

We believe this issue is now resolved, please try to access your exam timetable again, if you are still experiencing problems please log a ticket through go.bath.ac.uk/it-help and for urgent enquiries please contact the Exams Office emergency helpline on +44 (0)1225 387500

Created
Jan 18 at 08:44am GMT

We are aware that some students are unable to view their exam timetables through SAMIS, we are investigating.