Back to overview
Degraded

Problems accessing Microsoft 365 apps

Feb 02 at 09:35am GMT
Affected services
Software

Resolved
Feb 02 at 12:07pm GMT

Microsoft have now resolved this issue.

Created
Feb 02 at 09:35am GMT

We are aware a small number of users may be experiencing intermittent problems accessing M365 online applications, we are investigating.