Issue affecting Secure Downloads
Resolved
Nov 01, 2024 at 03:29pm UTC
We have identified the root cause of this issue, which has now been resolved.
Affected services
Updated
Nov 01, 2024 at 08:50am UTC
Our technical resolver teams are continuing to investigate the “HTTP Error 503; the service is unavailable” error message when attempting to access Secure Downloads.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Updated
Oct 31, 2024 at 01:55pm UTC
We are again investigating an "HTTP Error 503; the service is unavailable" error message when attempting to access Secure Downloads.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Updated
Oct 22, 2024 at 01:45pm UTC
This issue is now resolved.
Affected services
Created
Oct 22, 2024 at 01:10pm UTC
We are investigating an "HTTP Error 503; the service is unavailable" error message when attempting to access Secure Downloads.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services