Back to overview
Degraded
TOPdesk degraded (slow) mail import performance
Nov 25 at 05:00pm GMT
Affected services
Self-Service Portal (TOPdesk)
Resolved
Nov 26 at 10:50am GMT
Microsoft has confirmed that the root cause of this issue has been resolved.
Affected services
Self-Service Portal (TOPdesk)
Created
Nov 25 at 05:00pm GMT
We are aware of an issue in TOPdesk where mail imports are taking longer than usual to process. TOPdesk are aware of the issue and are investigating.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Self-Service Portal (TOPdesk)