Back to overview
Degraded

Network issues in 2 West

Dec 03 at 01:05pm GMT
Affected services
Network and Internet

Resolved
Dec 03 at 01:59pm GMT

This issue has been resolved.

Created
Dec 03 at 01:05pm GMT

We are investigating an issue affecting the Network (Ethernet and Wi-Fi) in 2 West.

We will provide further updates as soon as possible, and apologise for any inconvenience caused.