Back to overview
Degraded
iSecure Server Certificate expired
Dec 09 at 08:30am GMT
Affected services
Software
Resolved
Dec 09 at 09:35am GMT
This issue is now resolved.
Affected services
Software
Created
Dec 09 at 08:30am GMT
We are currently investigating an issue affecting the iSecure Server Certificate. iSecure hosts services such as the Secure Downloads Portal and the Accommodation Portal, among others.
We apologise for any inconvenience caused and will provide further updates as soon as possible.
Affected services
Software