Back to overview
Degraded

Self Service for macOS and iOS is unavailable

Apr 16 at 09:40am BST
Affected services
Software

Resolved
Apr 16 at 02:40pm BST

This issue is now resolved.

Created
Apr 16 at 09:40am BST

We are investigating an issue affecting Self Service for macOS and iOS. Users will not be able to install software at the moment.

We will provide further updates as soon as possible, and apologise for any inconvenience caused.