Back to overview
Degraded
Issue affecting the Tier 4 Booking System
Apr 24 at 11:45am BST
Affected services
Software
Resolved
Apr 24 at 12:40pm BST
This issue is now resolved.
Affected services
Software
Created
Apr 24 at 11:45am BST
We are investigating an issue affecting the Tier 4 Booking System.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Software