Back to overview
Degraded
Guest Wi-Fi Currently Unavailable
Apr 30 at 11:17am BST
Affected services
Network and Internet
Resolved
Apr 30 at 12:40pm BST
This issue has now been resolved.
Affected services
Network and Internet
Created
Apr 30 at 11:17am BST
We are aware of an issuing impacting access to Guest Wifi and are investigating.
Affected services
Network and Internet