Back to overview
Degraded
Issue affecting Business World (Agresso) Authentication
May 19 at 08:40am BST
Affected services
Business World (Agresso)
Resolved
May 19 at 09:35am BST
The issue affecting Business World (Agresso) authentication has now been resolved.
Affected services
Business World (Agresso)
Created
May 19 at 08:40am BST
We are investigating an issue affecting Business World (Agresso) Authentication.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Business World (Agresso)