Back to overview
Downtime
iTrent ESS and MSS currently unavailable
Jun 03 at 09:49am BST
Affected services
iTrent
Resolved
Jun 03 at 10:34am BST
iTrent ESS and MSS are now available, we apologise for any inconvenience caused by this unexpected down time.
Affected services
iTrent
Created
Jun 03 at 09:49am BST
iTrent is currently unavailable, we are investigating the cause.
Affected services
iTrent