Back to overview
Downtime
Account Issuing Unavailable
Jun 3, 2025 at 8:53am UTC
Affected services
Accounts and Passwords
Resolved
Jun 3, 2025 at 9:46am UTC
Account issuing is now available, we apologise for any inconvenience caused by this unexpected down time.
Affected services
Created
Jun 3, 2025 at 8:53am UTC
We are aware of an issue that is preventing the service desk issuing new accounts and are investigating.
Affected services